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License Agreement 

Before using ODV please read the ODV license agreement.  

https://odv.awi.de/fileadmin/user_upload/odv/docs/ODV_license_agreement.pdf
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1 Introduction 

This document contains in-depth descriptions on how to perform frequently occurring tasks 
with ODV.  
 
 

2 Collections  

2.1 Adding or Deleting Meta- and Collection Variables 

The sets of meta- and collection variables in a given ODV data collection are defined when 
the collection is created. ODV allows modifying these variable sets at any time and lets you 
add new variables, delete existing ones or change the properties of existing variables using 
the Collection>Properties>Meta Variables or Collection>Properties> Data Variables options. 
Before using these options you should create a zipped backup copy of the collection via Col-
lection > Create Snapshot. 

Note: If your collection is not of the latest format use option Collection > Properties > Con-
vert to ODVCF6 to convert the collection to ODVCF6 before proceeding. 

You add a new variable by pressing the New button and specifying label, units, the number 
of significant digits (numeric variables only), the quality flag schema to be used for this vari-
able, and the data type and byte length (TEXT variables only). Click OK to add the new vari-
able to the end of the variable list and repeat this procedure for all new variables to be add-
ed. 

You change the position of a given variables in the list by selecting that variable and clicking 
on the Top, Up, Down, Bottom buttons. You change the properties of an existing variable by 
selecting the variable and clicking on the Edit button. You delete an existing variable by se-
lecting the variable and clicking on the Delete button. Note that mandatory meta-variables 
cannot be deleted. 

After making the changes ODV will re-write the entire collection accommodating the new or 
modified variables in the new version. Please note that the new variables will not contain 
any data initially. You may selectively add data for the new variables and keep the data of 
other variables unchanged using the Merge Data (selected variables) import mode (see 
chapter 4.8 in the ODV User’s Guide). 

 

3 Station Maps 

3.1 Coastlines and Bathymetry from Shapefiles 

ODV comes with a moderate resolution global set of coastline and bathymetry/topography 
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resources for use in ODV station maps. Higher resolution sets based on ETOPO1, 
GEBCO_2014, IBCAO and RTOPO can be downloaded and installed via the View > Settings 
(on Mac OS odv > Preferences) option. Chapter 2.12 in the User’s Guide provides infor-
mation on how to install these high-resolution resources. 

If you require even better resolution and have coastline and bathymetry/topography data 
available as shapefiles you can adapt the ODV station map to use and display the features in 
the shapefiles.  

The procedure consists of two steps: first you remove the standard ODV map resources, 
then you add the desired shapefiles. 

1. Open the relevant collection (use <usr>/data/MapView to try out the procedure), 
right-click on the station map and choose Properties. Choose the Layers page and 
uncheck the Automatic selection and Draw color bar boxes. Remove the standard 
resources in Ocean bathymetry, Coastlines, Land topography and any other layer 
containing entries. Do this by selecting the layer, pressing Compose and removing all 
entries in the Selected list (select all and press >>). Press OK when done. An empty 
station map will be drawn. 

2. Add one or more shapefiles using the following procedure. If you have a series of ba-
thymetry contours start with the deepest and work your way up. To add a shapefile 
right-click on the station map and choose Extras > Add Graphics Object from File > 
Shapefile. Navigate to the shapefile and select the file. On the Shapefile Object – 
Properties dialog specify line and fill properties. Set the Fill Color to (none) if you are 
uncertain whether the file contains properly closed polygon data. 

The figure below shows an example from the Zeebrugge/Oostende region. 
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3.2 Custom Coastlines and Bathymetry 

ODV comes with a moderate resolution global set of coastline and bathymetry/topography 
resources for use in ODV station maps. Higher resolution sets based on ETOPO1, 
GEBCO_2014, IBCAO and RTOPO can be downloaded and installed via the View > Settings 
(on Mac OS odv > Preferences) option. Chapter 2.12 in the User’s Guide provides infor-
mation on how to install these high-resolution resources. 

If you need high-resolution coastline and bathymetry files for a region not included in the 
ODV distribution and if you have such high-resolution data available, here is how to produce 
ODV usable files. 

Preparing New Files 
The data for the coastline and bathymetry contours must be in separate files. Use 
World.coa as name for the coastline file. The names of the bathymetry files must follow the 
xxxm.coa scheme, where xxx represents the depth value of the respective contour (no 
white space between the depth value and the m; example: 1000m.coa). For a sample .coa 
file see the samples directory of your ODV installation. 

The latitude/longitude coordinates of the coastline or depth contour are stored in individual 
polygon segments (see Figure below). The first nS nodes of a segment represent a part of 
the actual coastline or bathymetry contour. This part of the segment is stroked when the 
outline of the contour is requested. In addition, each segment can have an optional, second 
part which will not be stroked but is only used to properly close the segment. Segments that 
also contain this second part can be filled and/or stroked. The total number nT of nodes in 
any segment must not exceed 1500. If a segment has no second part, the number of stroke 
points nS must be equal to nT. 

 

 
Figure 3-1: Schematic diagram of an ODV coastline/bathymetry segment. 

 

Latitude/longitude coordinates are decimal values: longitude is in degrees East (0 – 360) 
and latitude is in degrees North (-90 – 90). A polygon segment in a .coa file is specified as 
follows: 



Version 5 

 4 

nT  nS 

lat1 lon1 

..... 

latnT lonnT 

 

where nT is the total number of vertices for this segment and nS is the number of ”true” 
coast/bathymetry vertices. nT may be larger than nS, in which case vertices nS +1 .... nT  are 
used to close the segment (land-side closure). These extra vertices are not shown when the 
segment is stroked. Note that both, nT and nS, must be smaller than 1500. On the line fol-
lowing the last vertex of a segment, the next segment is started by specifying its nT and nS 
values. There is no blank line between segments. To indicate the end of the file put ”0 0” in 
the last line of the file. .coa files have to be converted to binary format (.cdt files) before 
they can be used by ODV. A .coa to .cdt converter (coa2cdt.exe) is included in the ODV dis-
tribution package for Windows. To use the coa2cdt converter do the following: 

1. In the directory containing the .coa files create a file coa2cdt.inp and enter the 
names of the .coa files to be processed. Put one file name per line and omit the .coa 
extension. 

2. In a DOS box change to the respective directory and execute coa2cdt.exe. Make sure 
the coa2cdt.exe executable is in your path or in the .coa directory. Also make sure 
that the .coa files satisfy the .coa format, as described above. 

The .cdt files created by coa2cdt.exe are platform-independent and can be used on all sup-
ported platforms. 

Please note that if you want to fill the bathymetry and coastlines, you have to close all poly-
gons in the .coa files, and the interior of the polygons must represent the areas that are 
shallower than the respective depth contour or coastline. If your depth contours or the 
coastline does not consist of closed polygons, you can still use them with ODV, however, 
you should select a line drawing mode and avoid filling in those cases.  Use the Display Op-
tions menu of the map to change display settings accordingly (see Using New Files below). 

Installing New Files 
When installing the binary version of coastline-, bathymetry-, topography and overlay files 
follow these instructions: 

• Create a new subdirectory of the ODV coast directory (normally: c:\Program 
Files\Ocean Data View (mp)\coast) and choose a descriptive name for it (e.g., 
GulfOfMaine). This directory is the base directory of the new file series.  In the new 
directory create subdirectories bathymetry, topography, and overlays. 

• Copy the coastline file (normally called World.cdt) into the series base directory 
(e.g., c:\Program Files\Ocean Data View (mp)\coast\GulfOfMaine). 

• Copy all bathymetry files (e.g., 100m.cdt, 500m.cdt, etc.) into the bathymetry subdi-
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rectory, all topography files into the topography directory and all general purpose 
overlay files (rivers, lakes, borders, etc.) into the overlays directory. If no topography 
and/or overlay files are available the respective directories remain empty. 

• If you want the new custom series to be used by ODV in automatic series selection, 
you must create a text file containing information on the domain and resolution of 
your series. The file name must be the same as your series name, and the extension 
must be .settings. In the example above, the file name would be GulfOf-
Maine.settings. The file must be located in the series’ base directory, e.g., in 
c:\Program Files\Ocean Data View (mp)\coast\GulfOfMaine. The format and con-
tents is described below. 

 

Example .settings file: 
 
[Domain] 
EastLongitude = 12. 
NorthLatitude = 63.0 
SouthLatitude = 47.5 
WestLongitude = -5. 
[Resolution] 
LatitudeRes = 0.015 
LongitudeRes = 0.015 

Contents: Domain longitudes are decimal degrees 
east (negative for deg W), latitudes are decimal 
degrees north (negative for deg S). Domains ex-
tending across the Greenwich meridian have neg-
ative WestLongitude but positive EastLongitude. Reso-
lution is given as decimal degrees. 

 

Using New Files 
To use the newly installed files in ODV maps do the following: 

• Invoke the map Display Options dialog box (e.g., right-click the mouse while over the 
map and choose Display Options) and select the Layers tab. 

• Choose the newly installed series name (e.g., GulfOfMaine) in the Series combo-box. 

• Compose the layer-set(s) of interest by selecting a layer-set (e.g., Ocean Bathymetry) 
and then pressing Compose. Select the contour files that you want to use in the 
Available list, set the desired stroke and fill properties and finally press << to add the 
files to the Selected list (note: if you forget to press << no file is added). To remove 
files from the Selected list select them and press >>.  

When specifying drawing characteristics follow these rules:  

(a) If the features should be outlined by lines (stroked), choose the appropriate line-
width, -type and –color or choose none as color, if you don’t want outlines. Note 
that due to limitations of the operating system, on some Windows versions thick 
lines will always be drawn as solid lines on the screen and in GIF, PNG and JPG 
output files. ODV PostScript files, however, honor your selection for any line-
width. 

(b) If the features should be filled choose the appropriate Fill color or none, if you 
don’t want filling.  
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If you choose automatic for line and fill colors, ODV will use default colors. Note that for 
some layer sets the automatic setting defaults to none. Also note that some feature files 
like rivers or borders should not be filled and you should explicitly set the fill color to none. 

ODV processes the layer sets in the order as listed in the Display Options dialog box. For a 
given layer set it draws the individual layers in the order in which they appear in the Select-
ed list (note that ocean bathymetry and land topography layers are sorted automatically 
when they are added). You should define sea-ice distributions in the pre-Coastlines set and 
lakes, rivers and borders in the post-Topography category. 

3.3 Custom Gridded Bathymetry Files 

Included in the ODV software distribution you find the gridded global bathymetric data of 
GEBCO 2014 subsampled to 6’x6’ resolution (file GEBCO_2014_6x6min_Global.nc in directo-
ry <install>/include). These data are used by ODV for two purposes: (1) the section bathym-
etry polygon when using sections and choosing GEBCO_2014_6x6min_Global.nc for section 
bathymetry, and (2) for construction of the gridding domains and sub-domains when using 
DIVA gridding in maps.  

Regional and global higher resolution versions of the GEBCO 2014 data as well as the 
ETOPO1 data are available for download and installation via the View > Settings (on Mac OS 
odv > Preferences) option. Chapter 2.12 in the User’s Guide provides information on how to 
install these high-resolution resources. 

If you have even higher-resolution gridded bathymetric data available for your area of in-
terest you may create your own high-resolution bathymetry file and use this resource for 
section bathymetry or DIVA domain selection. 

Your custom bathymetry file must be in netCDF format, have the .nc extension and contain 
elevation data on a regular longitude by latitude grid. Elevation values must be positive on 
land and negative in the ocean. The netCDF file must have the following structure: 

netcdf XXXXX { 
dimensions: 
       lon = 3601 ; 
       lat = 1801 ; 
variables: 
       float lon(lon) ; 
             lon:long_name = "Longitude" ; 
             lon:units = "degrees_east" ; 
             lon:range = "-180 - 180" ; 
       float lat(lat) ; 
             lat:long_name = "Latitude" ; 
             lat:units = "degrees_north" ; 
             lat:range = "90 - -90" ; 
       short Height(lat, lon) ; 
             Height:long_name = "Elevation" ; 
             Height:units = "m" ; 
} 

 

The names of dimensions and variables as well as the data types and the order of dimen-
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sions in the Height variable have to be exactly as given. Obviously the lengths of the lon and 
lat dimensions depend on the size of your grid, and the name of the file XXXXX is arbitrary. 
Note that the Height variable only stores the integer part of the elevation data. This limits 
the depth resolution in the file to ±1 m. 

Once created move the custom bathymetry file to the <install>/include directory. You use 
the custom bathymetry data for the section bathymetry polygon by choosing the newly cre-
ated file under Bathymetry>File on the Section Properties dialog. To use the new bathyme-
try file for DIVA domain selection choose the file under DIVA Settings>Map>File on the win-
dow’s Properties dialog. 

3.4 Custom Section Bathymetry 

By default the bathymetry polygon of sections is constructed using the Bot. Depth metadata 
of the stations. Alternatively, you can also use gridded bathymetric data from the <in-
stall>/include/GEBCO1.nc file or your own custom bathymetry (see previous section). As a 
third (and preferred) option you can construct the bathymetry polygon using along-track 
shipboard bathymetric data and provide the bathymetry polygon as .gob ODV graphics ob-
ject file. This method will usually result in the most detailed and accurate representation of 
the section bottom bathymetry and is recommended whenever shipboard bathymetric data 
are available. 

The section bathymetry .gob file must have the following structure (see also 
A7_bathymetry.gob example file in <install>/samples/SampleFiles.zip): 

 
1 %GOB1.03 graphics objects 
2 
3 :POLYGON 
4 coordinates=1 
5 clip=1 
6 iOrder=1 
7 isFixed=1 
8 doSmooth=0 
9 LineColor=16 
10 LineType=0 
11 LineWidth=3 
12 FillColor=16 
13 nPts=1187 
14 nStrokePts=1184 
15 12.6183 60.8 
16 11.6183 60.8 
17 11.5791 68.7 
18 11.5747 69.4 
19 11.5347 89.6 
 … 
 -36.9634 232.9 
 -36.9634 9500. 
 12.6183 9500. 
 12.6183 60.8 
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The first 14 lines of the file describe the graphical appearance of the polygon and its length. 
Then follow the X and Y coordinates of the polygon nodes, one node per line. The X values 
represent Section Coordinate values (Section Distance [km] or Longitude or Latitude as cho-
sen for the section), while Y is ocean depth in meters (positive downward). [For your infor-
mation, the example above uses latitudes for X.] The first nStrokePts nodes of the section 
polygon describe the bathymetry along the section; the last three nodes are needed to 
close the polygon.   
 
The format of the final 3 nodes is as follows: 
 

• Last X  Huge Y 
• First X  Same huge Y 
• First X  First Y 

 
The Huge Y of the closure points (9500 m in the example above) should exceed the maxi-
mum depth in the section plots. The maximum number of nodes nPts of the polygon is 
1500. You may have to subsample the shipboard bathymetry data to stay within this limit. 
 
Once created you use the .gob bathymetry file for the section bathymetry polygon by 
choosing the file under Bathymetry>File on the Section Properties dialog. 
 

3.5 Making Cruise Maps 

You can create full-page, high quality stations maps showing the currently selected stations 
of the open data collection using View>Window Layout>Layout Templates>Full Screen Map. 
Station maps may also be produced if you only have access to the station metadata (e.g., 
station positions, dates, etc.), but the actual station data are inaccessible. Here is how to 
proceed: 

• In an empty directory on your disk create an ASCII file that contains the longitude, 
latitude coordinates of the stations or way-points of your track. This file should have 
a descriptive name (e.g., CruiseTrack_xxx.txt, where xxx represents the name of your 
cruise) and it should comply with the generic ODV spreadsheet format specifica-
tions.  

As first line of the file use the following header line (note that columns are TAB separated): 
 
Cruise  Station  Type  yyyy-mm-ddThh:mm   Longitude [degrees_east]   Latitude [degrees_north]  Bot. Depth [m]  Dummy1   Dummy2 
 

Immediately following the header line, add one data line for each station or cruise track 
node and provide the following information for the respective station or node:  
 
Cruise The name of the cruise 
Station Station label or number 
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Type “B” 
yyyy-mm-ddThh:mm Station date and time 
Longitude [degrees_east] Decimal longitude of station  
Latitude [degrees_north] Decimal latitude of station  
Bot. Depth [m] Bottom depth at station location or “0” 
Dummy1 “0” 
Dummy2 “0” 
  

• On Windows systems drag-and-drop the prepared cruise track file on the ODV desk-
top icon. On all other platforms start ODV and open the cruise track file via 
File>Open and choosing file type Data Files (*.txt *.csv *.o4x). 

• Add new stations to the end of the cruise track file, if necessary, and drag-and-drop 
the updated file on the ODV desktop icon (Windows) or invoke ODV using the cruise 
track file name as a command line argument (all other platforms). 

 
 

4 Data Windows  

4.1 Custom Axis Labeling 

The labeling of X- and Y-axis of data windows is performed automatically by default. This 
includes automatic determination of labeled and unlabeled tic mark positions and the use 
of the variable’s label as axis title.  

You may customize the frequency of labeled and unlabeled tic marks by clicking on X-Axis 
Settings or Y-Axis Settings buttons on the Properties>Data page of the window’s Properties 
dialog and specifying values for Tic mark interval and Label Interval. 

You may switch off the automatic use of the variable’s label as axis title and use of a custom 
axis title in the following way: 

(1) Right-click the mouse while being over the existing X-axis title and choose option Copy 
Object. Do the same for the Y-axis. This will create editable and moveable copies of the 
existing annotations. 

(2) Uncheck the Automatic axis titles box on the Properties>General page of the window’s 
Properties dialog. 

(3) Drag the annotations created during (1) to their desired positions and change the text 
by right-clicking on the annotation and choosing Properties. 

 

4.2 Adding Station Labels to Section Windows 

Station labels can be added along the top margin of section plots (see Figure below) in the 
following way. First export the station labels as ODV annotation objects to a .gob file using 
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option Extras > Export as Graphics Object > Section Station Labels. If necessary then edit the 
.gob file to delete some entries in areas of dense station spacing or change the color or font 
size of specific entries. Finally add the labels to the section window via option Extras>Import 
Graphics Object from File>GOB File.  
 
If the station labels overlap with the Z-variable label (Oxygen in the example figure below) 
move this label upward. Note that if the Automatic axis titles option on the Properties > 
General page is checked this procedure has to be repeated after every redraw of the data 
window. You can avoid this by creating copies of the axis labels (Ctrl-C with the mouse over 
the respective label), unchecking the Automatic axis titles option and properly placing the 
axis labels ones and for all. 
 
Note that the station labels along the top margin are implemented as ODV graphics objects. 
You can manually change the properties of a given object by moving the mouse over it, 
right-clicking the mouse and choosing the Properties option, or simply by pressing Alt-P 
while the mouse is over the label. The easiest way to delete individual labels is to put the 
mouse over it and pressing the Del button. 
 

 
Figure 4-1: Section plot with selected station labels along the top margin. 

 

 

4.3 Visualizing Gridding Misfits 

Gridding algorithms allow the estimation of tracer values at arbitrary (x, y) points based on 
data values at sampling locations (xi, yi), i=1…n. The objective is to reproduce the features in 
the data as realistically as possibly. However, because of errors in the data it is generally not 
desirable to achieve a perfect match with the data at the sampling locations, but to allow 
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some misfits. Ideally, these misfits should show no systematic spatial patterns, the mean of 
the misfits should be close to zero, and the standard deviation of the misfits should be close 
to the error in the data. However, gridding algorithms often have problems to correctly re-
produce sharp gradients or property extremes, and, in order to assess the quality of a given 
gridded field, it becomes necessary to view and analyze the distribution of the gridding mis-
fits. 

The easiest way to produce a plot of estimate-data misfits at the data locations is via the 
data window’s statistics dialog (Extras>Statistics option or press F4 while mouse is over the 
data window). Pressing the Gridding Misfits button will create a misfit plot similar to the 
one shown in the lower part of Figure 3-2 below. 

ODV also allows exporting the x, y, z data values as well as the gridding misfits at the data 
locations using the Extras > Clipboard Copy option of the respective window context menu 
(obtained by right-clicking on the window). You may also simply press Ctrl-C while the 
mouse is over the respective window. On the Copying to Clipboard dialog that appears 
make sure to select Export data values and gridding misfits at data positions and check the 
Export station metadata box. ODV will then export the results to the clipboard. Open a text 
editor or Excel and paste the clipboard contents into it; then save the contents to an ASCII 
file. Choose .txt as file extension. 

Drop the newly created .txt file onto the ODV icon or open a new ODV instance and use File 
> Open to open the .txt file. Use option View > Layout Templates > 1 SCATTER Window to 
obtain a layout with a single SCATTER window and adjust the geometry of the window to 
match the geometry of the original window. Assign the X and Y variables of the original 
window as X and Y variables of the SCATTER window, and select the Estimated-Measured… 
variable for Z. You should obtain results as shown in Figure 5-1.  
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Figure 4-2: Gridded phosphate distribution (above) and estimation-minus-data differences (below). 

 

For the example shown in the Figure below the misfits are small and random in many parts 
of the deep ocean. Significant and systematic misfits are found in areas of sharp gradients 
and just south of the equator, where data from two different cruises overlap. You can ob-
tain further statistical information via the Extras > Statistics option or by pressing F4 while 
the mouse is over the misfit window. 

 

4.4 Visualizing Property Differences between two Layers 

Plotting the distribution of some tracer on given depth or density surfaces is a standard pro-
cedure in ODV involving the definition of appropriate isosurface variables and use of these 
as Z-variable of SURFACE scope data windows. Figure 4-3 below consists of two such plots 
showing phosphate concentrations at 10 and 250 m, respectively. 

Often there is great scientific interest in the concentration difference between two such 
layers. Here is the procedure for creating a map of phosphate concentration differences 
between 250 and 10 m using the World Ocean Atlas (WOA09_Annual) collection:  

1. Define isosurface variables Phosphate [µmol/l] @ Depth [m]=10 and Phosphate 
[µmol/l] @ Depth [m]=250 via option View>Isosurface Variables. 

2. Establish a proper window layout using option View>Layout Templates>3 SURFACE 
Windows. 

3. Use option Export>X, Y, Z Window Data as Reference to export the window data for 
later use with the Difference from Reference derived variable. 

4. Define Longitude and Latitude derived variables via View>Derived Variables. Open 
the Metadata group under Choices, select Longitude and click Add, then the same 
for Latitude. 

5. Still on the Derived Variables dialog open the Special group under Choices, select Dif-
ference from Reference and click Add. Then select the directory that received the 
reference data during step 3, open the ExportID.txt file and choose one of the winx 

http://odv.awi.de/fileadmin/user_upload/odv/data/WOA09/WOA09_annual.zip
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entries to be used as reference (win1 if we want to use Phosphate [µmol/l] @ Depth 
[m]=10 as the reference set). Identify the Longitude and Latitude derived variables. 
When prompted to identify Phosphate [µmol/l] @ Depth [m]=10 choose the Phos-
phate [µmol/l] variable. 

6. Define isosurface variable Phosphate – (Ref=<your view name>) [µmol/l] @ Depth 
[m]=250 and use this as Z-variable on the third data window. 

This will produce the difference plot below. 
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Figure 4-3: Phosphate concentrations at 10 and 250 m as well as the difference between the two layers. 

 

.  
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4.5 Estimating Z-Values at Arbitrary X/Y Points 

Often there is a need to obtain values of the Z-variable at arbitrary X/Y positions, where no 
direct measurement exists. One example from marine geology is the need to obtain hydro-
graphic or tracer data at the positions of sediment core or surface sediment samples. An-
other example is the need for obtaining Z-values on a regular X/Y grid when all direct meas-
urements are irregularly distributed. 

Here is the procedure to obtain values of a given variable (e.g., temperature) on a given 
isosurface (e.g., constant depth or constant density, etc.) at a set of sediment core loca-
tions. This procedure can easily be adapted for other use cases. 

1. Prepare an ASCII file containing geographic longitudes and latitudes as spreadsheet 
file with two columns separated by TABs. One easy way to create such a file is to 
open the sediment core ODV collection (assuming such a collection exists). Then 
choose Export > Window Data > Map specify output file name and directory and 
press OK on the Export Window Data dialog. 

2. Open the ODV collection from which you want to extract values. A good choice is 
World Ocean Atlas (WOA) that contains temperature, salinity, oxygen and nutrient 
data globally on 1x1 or 0.25x0.25 degree grids. Separate WOA ODV collections for 
annual, seasonal or monthly time periods are available from the ODV website 
https://odv.awi.de/data/ocean/. If, for instance, you want to obtain February tem-
peratures at 75 m depth at your sediment core locations, open the monthly WOA 
collection for February. 

3. Use option View > Isosurface Variables and define an isosurface variable for the 
property you want to extract, e.g., in our example Temperature [degC] @ Depth [m] 
= 75. 

4. Use View > Layout Templates > 1 SURFACE Window and establish as Z variable the 
isosurface variable defined in step 3 above. 

5. Right-click on this data window, choose Properties > Display Style, set Gridded Field 
DIVA gridding and adjust length scale settings if necessary. 

6. Finally, right-click on the data window again, choose Extras > 2D Estimation and lo-
cate the positions file created under step 1.  

ODV performs the requested estimation at all X/Y points in the positions file and creates an 
output file in the same directory that has _est appended to the position file‘s base name. 
The output file has the requested values in column 4. Columns 5 and 6 contain estimated 
gradients in x and y directions and can be ignored if not needed. No output is generated 
(field remains empty) if the gridding procedure estimate is unreliable at a given x/y point. 
This can happen if there is no nearby data value. 

 

 

https://odv.awi.de/data/ocean/
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5 Overlay Windows  

5.1 Contour Lines on top of a Shaded Field 

It is often useful to create section or isosurface plots where the distribution of one property 
(color shaded and/or contoured) is overlaid with contour lines of another property. Useful 
applications, of this technique are, for instance, density contours on top of any property 
section or depth contours on isosurface or isopycnal distributions. Example images are 
shown in Figures 4-1 and 4-2 below.  

To produce such plots, follow these steps: 

• Switch to window layout mode via View>Window Layout.  

• Setup the window for the underlying distribution (window a: define size and position; 
select a Z-variable for that window (property A) using the Properties option). 

• Create an overlay window for window a by moving the mouse over window a, clicking 
the right mouse button and selecting Create Overlay Window. Now select the Z-variable 
for the overlay window b (property B). Leave Window Layout mode by choosing Accept 
from the Window Layout context menu. 

• ODV will draw a default set of white contour lines for property B on top of the color dis-
tribution of property A. You may add or delete lines or modify properties of the contour 
lines of B by right-clicking on the overlay window by choosing Properties>Contours. 

• If satisfied, save the view for later use (View>Save View As). 

Note that the only way to access and modify the properties of a data window entirely over-
lain by another window (such as window a), is via the main menu View>Window Properties 
option.   

 

 
Figure 5-1: Section plot showing oxygen contour lines on top of color shaded phosphate distribution 
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Figure 5-2: Map showing isopycnals on top of color shaded phosphate distribution. 

 

 

5.2 Arrows on top of a Shaded Field 

It is often useful to create maps where the distribution of one property (color shaded 
and/or contoured) is overlaid with arrows of another vector property, such as ocean current 
velocities or atmospheric winds (see Figure 4-3 below).  
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Figure 5-3: Map showing wind arrows on top of color shaded distribution. 

 

To produce such plots, follow these steps: 

• Switch to window layout mode via View>Window Layout.  

• Setup the window for the underlying distribution (window a: define size and position; 
select a Z-variable for that window (property A), specify the display style, and possibly 
create some contour lines using the Properties option). 

• Create an overlay window for window a by moving the mouse over window a, clicking 
the right mouse button and selecting Create Overlay Window. Now select a Z-variable 
for the overlay window b (property B) that could be used for automatically coloring the 
arrows.  

• Edit the properties of the newly created overlay window by right-clicking on the window 
and choosing the Properties option (shortcut: Alt-P with the mouse over the window). 
On the Display Style page click on Original data, then on the combo box just below, and 
choose Arrows. Under X/Y Components choose the variables for the X and Y arrow com-
ponents, and then specify a scale, line width and color. Choosing (automatic) will auto-
matically set the arrow colors on the basis of the Z variable of the overlay window 
(property B). If you want all arrows having the same color, choose this color from the 
Color combo box. 

• Leave Window Layout mode by choosing Accept from the Window Layout context menu. 

• ODV will draw the arrows of the overlay window on top of the color distribution of 
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property A.  

• If satisfied, save the view for later use (View>Save View As). 

Note that the only way to access and modify the properties of a data window entirely over-
lain by another window (such as window a), is via the main menu View>Window Properties 
option.  

 

 

6 Data Quality Control  

ODV facilitates quality control of multi-parameter datasets by providing a range of automat-
ic and visual checks for easy identification and flagging of outliers and suspicious data. 
There is support for automated range checks of any basic variable (use option Tools>Find 
Outliers (Range Check)) as well as automatic statistical outlier checks for any data window 
currently applying the VG gridding method (use option Extras>Find Outliers (Field Check) of 
the data window’s popup menu). In both cases, ODV generates lists of suspicious data 
points and allows user controlled (point by point) or automatic flagging of the identified 
data. 

In addition to automatic quality control procedures, ODV also provides a wide range of 
easy-to-use visual and interactive methods for the identification and editing of outliers. For 
instance, you can plot all data from a given region or along a given section using data win-
dows of SCATTER or SECTION scope, easily revealing outliers and questionable data in the 
entire dataset. Flagging or editing the numerical values of the spurious data is as easy as 
clicking on such a data point in one of the data windows and invoking the Edit Data option 
of the variable that you want to modify. Note that all changes made to a data collection are 
logged in the collection logfile. The log record includes information about the sample that 
was changed, the date and time of the modification, the user who made the change and the 
computer on which the operation was performed. You can browse the collection logfile at 
any time using option Collection>Browse Log File.  

In the example below, outliers for salinity and oxygen can easily be spotted in the plots 
showing the data of an entire cruise. Clicking on such an outlier point selects it as current 
sample, which can then be edited and/or flagged. You can hide and exclude bad or ques-
tionable data from the analysis by establishing data quality sample filters. 
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Figure 6-1: Identification of outliers for a zonal section in the North Atlantic 

 

 

 

7 Importing XYZ Data  

Irregularly spaced or gridded data for some quantity Z at given X and Y coordinates are 
commonly provided in files using three-columns for the X, Y and Z values, respectively. Ex-
amples of such XYZ datasets are (1) maps of a given Z variable (X represents longitude, Y 
represents latitude), (2) vertical sections (X=along section coordinate, Y=depth) or (3) time-
evolution plots (X=some geographical coordinate, Y=time or vice versa). 

You can load all these XYZ files into ODV and you can analyze and display the Z data using 
the full suite of ODV functions. Note that the procedures described below can also be ap-
plied to data files with multiple Z variables, e.g., files with more than three columns.  

Here is how to proceed if the XYZ file represents a map: 

1. Create a new collection (choose a destination directory and collection name) with 
just two variables Depth [m] and Z-variable (use a descriptive label and appropriate 
units for the Z-variable), 

2. Import the XYZ file by choosing Import>ODV Spreadsheet and selecting the XYZ file 
(note that you have to choose file-type All Files, if the extension of the XYZ file is not 
.txt).  

3. On the Spreadsheet File Properties dialog specify (1) the column separation charac-
ter (the items from the header line should appear on separate lines in the Column 
Labels list), (2) the line number containing XYZ labels (keep 1, if no labels are provid-
ed), and (3) the line number of the first data line, 

4. On the Metadata Variable Association dialog associate the X-variable with Longitude 
[degrees_east] and the Y-variable with Latitude [degrees_north], 

5. On the Import Options dialog associate the Z-variable (source) with the second col-
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lection variable (target). Then click on the first collection variable (target), click on 
Use Default and specify the default depth value (use 0, if in doubt). 

ODV will import the data from the XYZ file, and lets you operate on the data in the usual 
way. To create a page with a map of the Z-variable create a data window with SURFACE 
scope. Modify the data window’s properties as usual, if this is necessary. 

 
 

8 Pre-computing Neutral Density  

Compared to most other derived variables, such as potential temperature, potential densi-
ty, or Brunt-Väisälä Frequency, that can be calculated easily and quickly on-the-fly, the cal-
culation of neutral density is computationally expensive. While this is not a problem for 
small data collections or when plotting only a small number of stations, using on-the-fly 
neutral density calculations with large collections and on long sections can be slow and inef-
ficient. If you are working with large datasets and need neutral density regularly, you should 
consider to pre-compute neutral density and store the results in collection files on disk. You 
can then use the pre-computed values from the disk files. The disadvantage of pre-
computing and storing these values is that they become out-of-date if any of the input data 
pressure (or depth), temperature and salinity changes (e.g., after data edits or calibration 
changes). It is the user’s responsibility to re-compute the neutral density values whenever 
pressure (or depth), temperature or salinity data have changed or have been added.  

To create a new collection with pre-computed neutral density values for all stations or a 
station subset of an existing data collection follow these steps: 

1. Open the existing collection and select the stations to be included in the new collec-
tion with pre-computed neutral density. If you want to process the entire collection, 
make sure you have a global map and the number of selected stations is identical to 
the number of stations in the collection (e.g., two numbers at the end of the status 
bar should agree). 

2. Define Neutral Density as a derived quantity using option View>Derived Variables. 

3. Export the station data including neutral density to a spreadsheet file, by choosing 
Export>ODV Spreadsheet. Specify a name for the new dataset (denoted as xxx.txt in 
the following) and make sure that Neutral Density is selected for output in the Select 
Variables for Export list.  

4. Use xxx.txt to create a new collection by simply dragging and dropping this file on 
the ODV desktop icon (Windows and some other platforms) or by starting ODV from 
a terminal window with “odvmp xxx.txt” (UNIX, Linux, Mac OS). The newly created 
collection xxx will have Neutral Density as one of its basic variables stored in the disk 
files. 
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9 Using ODV Graphics 

ODV graphics files of the entire canvas or individual data windows can easily be included in 
print documents, posters or on Web pages.  

To create GIF, PNG, JPG or TIFF files of the entire canvas or of individual plots press Ctrl-S 
while the mouse is over the canvas or the respective plot window and choose GIF, PNG, JPG 
or TIFF as output type. Then specify the desired resolution of the saved image and use the 
GIF, PNG, JPG or TIFF graphics files in your web pages or in text documents. For print docu-
ments you can either produce raster image files with high resolution, or you can use ODV 
PostScript (.eps) output instead. 

A number of typesetting and page design software applications support the import of En-
capsulated PostScript files (.eps) in mixed text/graphics pages (e.g., MS Word or compati-
bles, LaTeX, Adobe PageMaker, etc.). If you use the LaTex typesetting system, see the file 
Pssample.tex (usually in directory c:\Program Files\Ocean Data View (mp)\Samples) for an 
example on how to include PostScript graphics in TeX documents. Note that the required 
epsf and epsfig style files are also included in the samples directory.  

If you use Word or PageMaker or other publishing software follow these guidelines: Com-
pose your page as usual and insert the respective ODV PostScript file at the right position. 
Adjust the size of the figure appropriately. When you are done composing the page you can 
directly print the document on a PostScript printer. If no PostScript printer is available you 
need to have a PostScript printer-driver and the GhostScript/GhostView package 
(http://www.cs.wisc.edu/~ghost/aladdin/index.html) installed on your machine. In that 
case select the PostScript printer-driver as printer and redirect the output into a file. Open 
this file with GhostView and print to any printer connected to your system. 

 
 

http://www.cs.wisc.edu/%7Eghost/aladdin/index.html
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