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License Agreement
By downloading or using this Software, you agree to be bound by the following legal agreement
between you and the Alfred-Wegener-Institute for Polar and Marine Research (AWI). If you do
not agree to the terms of this Agreement, do not download or use the Software.
1. SCIENTIFIC USE AND TEACHING

Ocean Data View can be used free of charge for non-commercial, non-military research and
teaching purposes. If you use the software for your scientific work, please cite Ocean Data View
in your publications as follows: Schlitzer, R., Ocean Data View, https://odv.awi.de, 2018

2. COMMERCIAL USE
For the use of Ocean Data View or any of its components for commercial applications
and products, a special, written software license is needed. Please contact the address
below for further information.
3. MILITARY USE
AWI focusses its activities on civil purposes. Licenses for the Ocean Data View Software
for military purposes will only be granted after case-by-case assessments of the
requests. Please contact the address below for further information.
4. REDISTRIBUTION

Redistribution of the Ocean Data View software on CD-ROM, DVD, or other electronic media or
the Internet is not permitted without the prior written consent of the AWI. Please contact the
address below for further information.
5. WARRANTY DISCLAIMER

THE ODV SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO
THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU. SHOULD THE
SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
REPAIR OR CORRECTION.

IN NO EVENT WILL AWI, ITS CONTRIBUTORS OR ANY ODV COPYRIGHT HOLDER BE LIABLE TO
YOU FOR DAMAGES, INCLUDING ANY DIRECT, INDIRECT, GENERAL, SPECIAL, EXEMPLARY,
INCIDENTAL OR CONSEQUENTIAL DAMAGES HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE (INCLUDING BUT
NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES
SUSTAINED BY YOU OR THIRD PARTIES, A FAILURE OF THE SOFTWARE TO OPERATE WITH
ANY OTHER SOFTWARE OR BUSINESS INTERRUPTION).
Alfred Wegener Institute, Am Handelshafen 12, 27570 Bremerhaven, Germany,
E-Mail: odv_license at awi.de
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1 General Information
The ODV software is based on a new, object oriented source code allowing more flexible
metadata and data models and overcoming many limitations of previous versions.
1.1

Installation

You must install ODV on your computer before you can use the software. The latest ODV
installation files for Windows, Mac OS, Linux, and UNIX systems can be downloaded
from https://odv.awi.de/en/software/download/. Note that you have to register and
use your personal login data to get access to the download pages. Detailed installation
instructions are provided in INSTALL.txt files. Please see the License Agreement for ODV
usage rules.

SUPPORTED PLATFORMS: ODV runs on the following platforms: Windows (all
versions); Mac OS 10.5 or higher; Linux distributions released since June 2006 running
kernel version 2.6.15 or higher. ODV was tested under Debian 7.7, Ubuntu 14.0.4 and
16.0.4, and CentOS 7.

Windows platform note: The ODV installer associates the .odv and .var file extensions
with the ODV executable, e.g., double-clicking on these files will start ODV. You can also
open .odv or .var collections with ODV by dragging and dropping the .odv or .var file onto
to the ODV desktop icon, or starting ODV and opening the .odv or .var file via File>Open.

1.2

Customization

After installing ODV please use option View > Settings (on Mac OS odv > Preferences) to
customize ODV settings and optionally download and install high-resolution map
resources and gridded bathymetry files. See section 2.12 Settings in the User’s Guide for
more information.
1.3

ODV User Directory

During installation a sub-directory ODV is automatically created in the user’s document
directory. This is the ODV user directory and contains map resources as well as palette,
macro, gazetteer, command or graphics objects files in varies sub-directories. Two
example collections MapView and SAVE are provided in the data subdirectory. When
maintaining your own ODV data collections please create separate sub-directories
within the data directory.

Users may create custom palette, macro, gazetteer, command or graphics objects files in
the respective ODV user directory. It is very important to save the customized files
under new, user specified names, otherwise the user files would be overwritten and lost
the next time a new ODV software version is installed. The full user directory path as
well as other ODV installation settings can be retrieved via Help > About ODV or odv >
About odv on Mac OS systems.

1.4

Data Model

ODV introduces a new data model and storage format, suitable for marine and other
environmental profile, trajectory and time-series data. Individual stations in a data
collection are described by a set of metadata. There is a minimum set of mandatory
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metadata, including cruise and station names, longitude, latitude as well as date and
time. In addition, users may specify an arbitrary number of optional string or numeric
metadata. Except for longitude and latitude, all other metadata values may be missing.
As for metadata variables, the number of data variables (e.g., the variables holding the
actual data) in ODV collections is unlimited, and the value types may be numeric or
string. ODV supports a variety of numeric metadata and data variable value types
ranging between single-byte integers and 8-byte double-precision real numbers. Quality
flag values of metadata and data variables can be encoded using one of the supported 16
popular quality flag schemes in the community.
ODV lets you subset and filter stations as well as samples, and provides separate sets of
station and sample selection criteria. Every data window now uses its own sample filter,
and filtering can be by quality flags and/or value ranges (numeric ranges or string
wildcard expressions).

Newly created ODV collections use the new data model and file storage format. ODV data
collections are platform independent, and may be transferred between all supported
systems.
1.5

Data Import

ODV collections are extendable, and new data may be added at any time using one of the
options from the Import menu. ODV supports a large variety of import data formats and
data types, and the user invokes the import by choosing the menu option matching the
particular format and data type. A file open dialog appears allowing selection of one or
more data files to be imported. Alternatively, the user may also select a .lst list file
containing the list of file names to be imported. The latter case allows import of files
from more than one directory in a single import step.

ODV supports import of data from arbitrary spreadsheet files. Spreadsheet files
satisfying the ODV generic spreadsheet file rules can be imported automatically by simply
dragging and dropping the files onto ODV. The ODV generic spreadsheet format allows
specification of extended metadata and data variable properties.
1.6

Backward Compatibility

ODV is backward compatible in the sense that existing collections and configuration files
created under previous ODV versions are fully supported.
1.7

Getting Help

For more help, use Help > Getting Started or Help > User’s Guide. Context-sensitive help is
available on many ODV dialogs by pressing the Help button. PDF versions of the help
documents can be downloaded from the ODV website
https://odv.awi.de/en/documentation/.
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2 Application Window Elements

Figure 1: Elements of the ODV application window.

The ODV application window consists of the following elements.
Menu Bar:

Views Bar:

Canvas:

Status Bar:

Current Station Window:
Current Sample Window:

Isosurface Data Window:

The menu bar provides access to the main menus.

The views bar contains clickable tabs for each open view as well
as a set of buttons for (1) opening more views (plus button), (2)
undoing view modifications (undo button), (3) redoing view
modifications (redo button), (4) switching to/from layout mode
(layout button), and (5) saving modified views (save button).

The graphics canvas contains a map (always present) and an
unlimited number of data windows. The canvas, the map, and the
data windows may contain an unlimited number of graphics
objects, such as text annotations, symbols or user-defined shapes.
Separate status bar panes provide (1) status information, (2)
coordinates at current mouse position or a progress bar, and (3)
the number of currently selected stations, the total number of
stations in the collection, and the name of the current view. An
asterisk (*) in the View Information pane indicates that there are
unsaved view changes.

Metadata values of the current station (marked in the map with a
red cross).

Data values and quality flags of the current sample (marked in
data windows with a red cross). Only data satisfying the current
sample selection criteria are shown.

Isosurface values of the current station.
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Left-clicking on station or data marks in the map or a data window selects the respective
station or sample. Right-clicking on most window elements brings up context menus
with different, element-specific options. Resting the mouse over data listing items brings
up popup windows with detailed data information.
The map displays the subset of stations in the collection that satisfy the current station
selection criteria (valid stations). It maintains a pick station list and may have a section.
Data windows can have one of the following scopes:
•
•
•
•

STATION, showing X/Y data of the picked stations. Picked stations are marked in
the map using the same mark style as in the data windows.
SCATTER, showing X/Y/Z data of all selected stations shown in the map.
SECTION, showing X/Y/Z data of all stations inside the section band.

SURFACE, showing isosurface X/Y/Z data of all selected stations shown in the
map.

The current window layout and parameter settings are collectively called a view. Views
are stored in files for later re-use. You can have more than one view open at any given
time. Clicking on a particular view tab switches to this view.
The canvas always shows the station map and an unlimited number of data windows.
Geometry and position of the map and the data windows may be modified at any time.
Data windows may be deleted, but the map will always be present.

The properties of the map and data windows can be modified by right-clicking on the
window and choosing Properties from the respective popup menu. The object’s
properties dialog will appear, letting you change the parameters and display options of
the object. As a quick way of bringing up the same Properties dialog you can press the
Alt-P shortcut key while the mouse is over the map or data window.
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3 Keyboard and Mouse Actions
3.1

Common Mouse Actions (Ready Status)

Action

Object

Response

L-Click

Map

Selects the closest station as current station.

Map

Selects the closest station as current station. Allows selection from list of
stations at the same location.

Data Window
Shft L-Click

Data Window
L-DbleClick

Map

L-Drag

GObject

Ctrl L-Drag 1)

Canvas, Map,
Data Window

R-Click 2)

Data Window

Shft R-Click 3)

Selects the closest sample as current sample and the parent station as current
station.

Selects the closest sample as current sample. Allows selection from list of
samples at the same location.

Adds the closest station to the pick list and adds the data of this station to
STATION data windows.
Drags the graphics object (if object allows dragging).
Drags the canvas (if scroll bars are present).

Map

Quick-zooms into the map.

Canvas, Map,
Data Window,
GObject, Data
List Windows

Invokes element-specific context menu.

Map, Data
Window

Quick-zooms into the data window.

Invokes the Extras menu of the map or data window.

On Mac OS systems hold down the “Apple” key and click-and-drag the mouse.
On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button
click.
3) On Mac OS systems with a single-button mouse hold down the Alt and Shft keys while clicking the mouse to simulate a Shft right
mouse button click.
1)
2)

3.2

Common Shortcut Keys

Key

Response

Enter or

Adds the current station to the pick list and adds the data of this station to the STATION data
windows (if any). In window layout mode, accepts the current layout and returns to normal
mode.

Return

Del or

Backspace
#
→

Deletes the graphics object pointed to by the mouse, or, if not over an graphics object, removes
the current station from the pick list and removes the data of this station from STATION data
windows (if any). In window layout mode, deletes the window containing the mouse.
Allows selection of a new current station by internal sequence numbers.
Selects the next station as current station.

8

←

Selects the previous station as current station.

HOME

Selects the first sample as current sample.

↓

Selects the next sample as current sample.

↑

Selects the previous sample as current sample.

END

Selects the last sample as current sample.

PgDn

Steps down (forward) the current sample.

PgUp
Ctrl-? 1) (Mac)
F1 2) (others)
F4 2)
F5 2)

Shows the ODV help document.

Shows the data statistics of the window containing the mouse.

Redraws the entire canvas or the window containing the mouse.

F8 2)

Switches to full-screen map layout.

F9 2)

Switches to six STATION window layout.

F10 2)

Switches to two SCATTER window layout.

F11 2)
F12

Steps up (backward) the current sample.

Switches to three SECTION window layout.

2)

Ctrl-Plus or

Ctrl-Wheel 1)

Ctrl-Minus or
Ctrl-Wheel
Ctrl-A 1)
Ctrl-C 1)
Ctrl-F 1)
Ctrl-N 1)

Ctrl-O 1)
Ctrl-R 1)
Ctrl-S

1)

Ctrl-W or
Ctrl+F4 1)
Ctrl-Z
Alt-D
Alt-P
Alt-S
Alt-W
Alt-Z
Shft-E
Shft-L
Shft-S

1)

Switches to one SURFACE window layout.
Zoom in at mouse position.

Zoom out at mouse position.

Adds an annotation to the window containing the mouse.

Copies the data of the window containing the mouse to the clipboard, or, if the mouse is over a
graphics object, creates a copy of that object.
Adjusts the X, Y, Z ranges of the window containing the mouse (or of all data windows) to full
range.
Creates a new ODV collection.

Opens an ODV collection, netCDF file, or supported ASCII data file.

Move or resize the window containing the mouse (window layout mode only).

Saves the window containing the mouse (or the entire canvas) to an image file (gif, png, jpg, or
PostScript).
Closes the current collection or netCDF file.
Undoes the last change.

Allows definition of derived variables.

Allows property changes of the window or graphics object containing the mouse.
Allows change of the station selection criteria.
Allows change of the window layout.
Undoes all changes.

Edits the meta- or sample data.
Loads view settings from a file.

Allows change of the sample selection criteria (range and quality filters).
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Ctrl-, 1)

(Mac only)

ESC

Ctrl-Q 1) (Mac)

Alt-F4 (others)

Aborts the current operation (if supported by operation). In window layout mode cancels all
layout changes made and returns to normal mode.
Exit ODV.

On Mac OS systems hold down the Apple key while pressing the other key.
On Mac OS systems hold down the fn key while pressing the function keys. The fn key is not necessary if you check the Use
all F1, F2 etc. keys as standard function keys box in the keyboard tab of the Mac system preferences.

1)
2)

3.3

Opens the general settings dialog.

Zooming and Z-Zooming

When zooming into the map, a data window or the color bar of a data window, ODV temporarily
switches to Zoom or Z-Zoom mode.
Action

Object

Response

L-Drag

Boundaries and corners
of zoom rectangle

Resizes the zoom rectangle.

L-DbleClick or
ENTER

anywhere

Accepts current settings and terminates zooming.

R-Click 1) or ESC

anywhere

Discards changes and aborts zooming.

On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button
click.

1)

3.4

GetPoints Mode

When defining sections, lines, polylines or graphics objects, ODV temporarily switches to
GetPoints mode allowing to enter one or more x/y points by clicking the left mouse button. Note
that the cursor changes to a cross during GetPoints mode.
Action

Object

Response

L-Click

Canvas, Map, Data
Window

Add current point to list.

anywhere

Accept current settings and terminate GetPoints.

R-Click 1)
ENTER
ESC

Canvas, Map, Data
Window

Remove closest point from list.

anywhere

Abort GetPoints.

On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button
click.

1)
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